Help - Support Browsers and Plug-Ins

The new Baird OnLine provides our clients with the most up-to-date technology and secure online experience when viewed with Internet Browsers that meet our new minimum browser requirements. We recommend using any of the supported Internet Browsers listed below.

If your current Internet Browser does not meet our minimum requirements, please upgrade to one of the following supported versions.